ewi-usb configuration issue

Please post here topics concerning use of windcontrollers with our instruments
Post Reply
RedRed
Posts: 2
Joined: Sun Jan 24, 2016 8:17 pm

ewi-usb configuration issue

Post by RedRed » Mon Jan 25, 2016 2:30 pm

Hi there

First post, just purchased The Trombone 3 and looking forward to using it.

I have the ewi-usb working with the Garritan Aria software, but I'm having trouble getting the ewi-usb configured within Kontakt to use The Trombone.

Within Kontakt I select Options/Midi Tab and I see the ewi-usb listed in the Input Device list, however, when I try to set the Device Status to be e.g. 'Port A', it won't set the status, it remains set 'Off'. Note: The Aria software is still running at this point.

Within the Garritan Aria Preferences Dialog I have the In and Out MIDI devices set as the ewi-usb only and the driver settings set to the ASIO drivers of my soundcard i.e. a Fireface800. I believe this is all correct?

If I close the Aria software I am able to set the Device status in Kontakt to be 'Port A'. However, I'd have thought the Aria ewi-usb software would need to be running for Kontakt/Trombone to work correctly? So I'm not sure how useful it is being able to set it in this scenario.

Anyway, on one occasion, after closing the Aria software and setting the device status I was able to get sounds out of The Trombone, however, they didn't seem that controlled to me. Also, subsequent attempts, after closing everything down and restarting from scratch and following my above procedure for producing sounds, have not been successful.

Any suggestions as to what I might be doing wrong would be very welcome.

Thanks
Terry

MSchnell
Posts: 501
Joined: Mon Jul 09, 2012 5:06 pm
Location: Krefeld, Germany
Contact:

Re: ewi-usb configuration issue

Post by MSchnell » Mon Jan 25, 2016 5:26 pm

I am not absolutely sure, but I seem to remember that within the PC OS, the midi connections are 1->1 so you can only connect a single Midi receiver to a Midi sender.

You could either use dedicated Midi device software such as MidiOx to allow for Midi routing ("virtual midi cables"), or (much more versatile) you use a VST host software (Reaper, Cubase, Forte, ...) and load your instruments (e.g. Kontakt) as VST plugins.

-Michael
Last edited by MSchnell on Tue Jan 26, 2016 2:10 pm, edited 1 time in total.
Music examples -> http://www.boa-sorte.de

RedRed
Posts: 2
Joined: Sun Jan 24, 2016 8:17 pm

Re: ewi-usb configuration issue

Post by RedRed » Tue Jan 26, 2016 1:50 pm

Hi Michael

Thanks for your response. I think you may well be right.

I spotted this book on Google Books.

Playing The Akai EWI USB Electronic Wind Instrument (2015-10-16)
By Amen Zwa, Esq.

In there it says:

"When you save 'Setup Controls', 'Performance Controls' and 'Controller Config' in the Aria software, these values are immediately sent to the ewi-usb and the instrument retains these values even after it has been switched off, because they are stored in its EEPROM".

I was under the false impression that Aria always had to be running for Kontakt to get hold of the configuration information - didn't realize it was stored on the ewi.

So it makes sense that Aria should shutdown when using the ewi-usb with Kontakt. It also explains why The Trombone worked for me on that one occasion. All I need to do now is work out exactly what I did to make it work.

There looks to be more useful information in that book - you can see it at this link:

https://books.google.co.uk/books?id=I_GaCAAAQBAJ&pg=PA48&lpg=PA48&dq=is+controller+configuration+stored+on+ewi-usb?&source=bl&ots=jQkUpCeLoc&sig=ZXOzzG1I2HyFC-KuIWEcVz9Y7kU&hl=en&sa=X&ved=0ahUKEwiJ0Oq_x8fKAhXFWxQKHV7AAv8Q6AEIVTAI#v=onepage&q=is%20controller%20configuration%20stored%20on%20ewi-usb%3F&f=false

Thanks again
Terry

MSchnell
Posts: 501
Joined: Mon Jul 09, 2012 5:06 pm
Location: Krefeld, Germany
Contact:

Re: ewi-usb configuration issue

Post by MSchnell » Tue Jan 26, 2016 2:12 pm

Great that you got it running !

-Michael
Music examples -> http://www.boa-sorte.de

frokka
Posts: 34
Joined: Fri Feb 05, 2016 2:16 pm
Location: Norway

Re: ewi-usb configuration issue

Post by frokka » Thu Feb 18, 2016 6:57 pm

There is another way of configuring the EWI also, in case Aria doesn't work. This software from Cognitone for Windows and Mac:

http://www.cognitone.com/downloads/index.stml?p=4

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest